Централизованное обновление серверов🔗

В приложении Macroscop Конфигуратор во вкладке /config/img/ico-tab-servers.png Серверы при выделении пункта Общие настройки на вкладке Обновление размещены инструменты централизованного обновления серверов.

../../_images/servers-updating.png

Перед обновлением серверных приложений необходимо загрузить пакет обновления в приложение Macroscop Конфигуратор на данном компьютере. Загрузка осуществляется по ссылке Загрузить обновления; либо Заменить пакет обновлений, если уже загружен пакет обновлений другой версии. Загружать следует файл полного дистрибутива: MacroscopMainCommon Installer.exe.

Примечание

Актуальную версию Macroscop можно скачать на сайте www.macroscop.com со страницы Поддержка / Дистрибутивы.

Для обновления сервера нужно выполнить следующую последовательность действий над сервером в таблице Обновление серверов системы:

  • Для сервера со статусом Не загружено выполнить действие Загрузить ....

  • Для сервера со статусом Загружено выполнить действие /img/ico-down.png Установить версию ....

/config/servers/img/server-updating-load.png

/config/servers/img/server-updating-install.png

/config/servers/img/server-updating-ok.png

Для сервера со статусом Установлено доступно действие /img/ico-undo.png Откатить на версию ..., возвращающее сервер к предыдущей версии. При этом все настройки сервера возвращаются к состоянию на момент обновления с предыдущей на текущую версию.

Примечание

Если сервер обновлялся с помощью процедуры централизованного обновления несколько раз, то можно в обратной последовательности, пошагово, откатиться до любой из версий.

Предупреждение

Централизованное обновление доступно только для приложений Macroscop Сервер и Macroscop Standalone. Для приложений Macroscop NVR централизованное обновление недоступно.

Примечание

Серверные приложения Macroscop можно обновлять не только до более новых, но и до более старых, по сравнению с текущей, версий — но только в том случае, если первые два числа номера версии совпадают.

Предупреждение

Для обновления серверов до версии 4.0 или выше необходимо предварительно обновить эти серверы до версии 3.6.57 или выше.